Raspberry pi 3 & Artic F12 Silent

Hallo zusammen ,
würde gerne meinen Artic F12 Silent Pc Lüfter mit dem Raspberry Pi ansteuern.


Folgende Probleme ergeben sich bei meinem Vorhaben:

– Der Lüfter selbst sollte mit 12V DC 0.08A betrieben werden. Der Raspberry gibt aber max 5V her,
sollte aber eigentlich auch gehen, halt nicht auf voller Leistung.

– Kein Plan von den 3 Kabeln am Lüfter. Welcher was ist. Konnte nirgendswo angaben dazu finden, lediglich eins von drei Kabeln ist mit einem weissen Strich markiert. Bedeutung???

Bevor ich meinen Pi zerstöre, durch einfaches ausprobieren, hoffe ich das mir einer von euch diesbezüglich weiterhelfen kann.

Vielen Dank im voraus

Das weiß markierte müsste das stromführende sein, und das daneben anliegende das zurückführende.
Aber bin da auch immer vorsichtig.
Hatte mir auch mal welche zerlegt beim rumprobieren.
Mich wunderst das kein gelbes mit bei ist, zwecks lüftersteuerung?

Der Zweck ist einfach nur umluft. Habe hier ein 2 poligen Lüfter bereits am laufen auch mit 5 V , ist aber zu wenig, deshalb möchte ich gegenüberliegend noch einen betreiben.

Ich benutze die ja auch nur zur Umluft auf kleinem Raum.
Hab mir aber nen Netzadapter besorgt der auf 4polig geht, und auf dem 4poligen hab ich dann 6 Abgänge mit 3poligen.
Da brauchst dann nur noch zusammenstecken.
Nutze aber auch nicht raspberry usw.
Da habe ich überhaupt kein Plan von.

Und ich habe leider keinen weiteren Netzadapter da, deshalb dachte ich den über den Pi laufen zu lassen, da er eh schon in der Box ist.
Vielen Dank soweit :+1::+1::+1::+1:

Du hast 3 Pins (+, GND und Tacho), letzterer wird ignoriert.
Um rauszufinden welcher welcher ist, schau dir einen Lüfter mit farbigen kabeln an:

image

schwarz = GND
rot = +
gelb = Tacho

um ihn mit Strom zu versorgen brauchst du ein netzteil mit 12V, da der Lüfter sonst:
a) langsamer läuft oder
b) der Pi abschmiert wenn der Lüfter zuviel Strom zieht.

kannst ein billiges Netzteil dafür verwenden.

Um ihn mit dem Pi zu steuern würdich ein Relais nehmen. Dabei unterbrichst du die + Leitung und schraubst beide „Enden“ am Relais fest, dass du dann mit dem Pi steuerst.

1 Like

Das er langsamer laufen wird nehme ich gerne in Kauf.
Abschmieren sollte er nicht, da der gipo vom pi nicht mehr als 5V hergibt, oder verstehe ich da was falsch?
Wie ihr merkt habe ich in sachen Elektrik nicht viel Ahnung

Habe grade an der Steckverbindung vom Lüfter bezeichnungen entdeckt, mit denen ich absolut nix anfangen kann aber vielleicht ihr.:laughing::laughing::laughing:

In deinem Bild ist - ganz oben in der mitte + und ganz unten ist die Rückgabe der Drehzahl (für dich unintressant). Den Lüfter darfst du keinenfalls direkt über einen GPIO versorgen, da dieße erstens nur 3,3V ausgeben und auch nur maximal mit 8mA belastet werden dürfen. Deshalb brauchst du ne mosfet oder nen Transistor mit dem nu den Lüfter ansteuerst. Zudem kannst du dan den Lüfter auch an 12V betreiben und über PWM die Geschwindigkeit regulieren.

http://galacticbox.net/2018/02/11/fan-control-rpi/

1 Like

@CheapBastard Habe dieses Sensorkit noch hier rumliegen oben in der Ecke steht Voltage Translator und ein 5V Relais Modul ist auch dabei. Kann ich es damit umsetzten??

ja kannst du auch aber dan kannst du halt nur ein oder ausschalten nicht die Geschwindigkeit regulieren.

Und je nach
dem welches Relaismodul du hast kannst du dießes auch an 3.3V betreiben

Cool vielen Dank …momentan würde ein und aus reichen und zum ansteuern bräuchte ich dann den mosfet?? Die sind doch auch in allen Laptop´s und so verbaut oder?? Habe hier nähmlich auch noch ein paar nicht zu gebrauchende rumfliegen :laughing::laughing::laughing:.Könnte ich da einen passenden ausbauen??

Mosfets und transistoren findest du eigentlich in so ziemlich allen Geräten irgendwo. Sind halt in den meisten modernen oder kompackten Geräten als SMD bauteile verbaut, wass es schwieriger macht dieße abzulöten und wieder zu verbauen

Okay learning by doing :smile::smile: erstmal versuche ich ihn normal zum laufen zu bekommen. Werde mich aber vor inbetriebnahme nochmals bei euch absichern da ich grade auf folgendes gestoßen bin.

Kein Stress, arbeitest nicht mit netzstrom :slight_smile: 12V im Fall vom Lüfter.

:rofl::rofl::rofl: Okay wie gesagt voll der Noob mit Elektrik. Aber NO RISK NO FUN.

Ne dir kann da nichts passieren, so wies aussieht kannst du bei deinem Relais leider nicht die Spulen und Schaltspannung trennen. Müsstest ausprobieren ob der Relais mit 3,3V auch schon schaltet. Falls der Raspi aber 5V an den GPIOa tolleriert kannst du auch an 5v anschließen das weis ich aber leider nicht auswendig

Okay , den pi habe ich nach anleitung mit dem Modul verbunden.
http://sensorkit.joy-it.net/index.php?title=KY-019_5V_Relais_Modul


So, nun müsste ich den Lüfter an das Modul anschließen :thinking: Tja welches kabel wohin :thinking::thinking::thinking:

Demnach müssten die beiden Kabel eingesetzt werden. „NC“ für "normally closed ???oder „NO“ für „normally open“??

@CheapBastard @koreander So konnte nicht abwarten und habe einen Test gewagt. Was passiert ist, ist das das Modul geblinkt hatte.
Lüfter blieb aus. Wird wohl an dem Script dazu liegen. wäre sehr, sehr dankbar wenn mir einer beim umschreiben helfen würde. Lüfter wurde auf NO angeschloßen.


her ist der CODE dazu:

Ich würde den Lüfter mal im NC Konfiguration anschließen. Wenn du dann Strom gibst, sollte er ganz ohne Code laufen. Wenn das nicht funktioniert stimmt bei der Schaltung irgendwo was nicht.

Edit: Meinte NC :slight_smile: das wo das Relais öffnend funktioniert ^^

okay ,hatte bereits beide varianten probiert, ohne erfolg. Ich versuche es nochmal.
Irgendwie dachte ich jetzt das der Code dazu garnicht passet, das er halt nur das Relais zum blinken bringt.
Müsste mich jetzt hier komplett einlesen mit dem programmieren.